예제 #1
0
파일: Icon.cs 프로젝트: s7loves/pesta
 /**
 * Substitutes the icon fields according to the spec.
 *
 * @param substituter
 * @return The substituted icon
 */
 public Icon substitute(Substitutions substituter)
 {
     Icon icon = new Icon(this);
     icon.content = substituter.substituteString(Substitutions.Type.MESSAGE, content);
     return icon;
 }
예제 #2
0
파일: Icon.cs 프로젝트: s7loves/pesta
 /**
 * Creates an icon for substitute()
 *
 * @param icon
 */
 private Icon(Icon icon)
 {
     mode = icon.mode;
     type = icon.type;
 }