Пример #1
0
        public void visit(XmlElement element)
        {
            Preload preload = new Preload(element, _base);

            if (preloaded == null)
            {
                preloaded = new List <Preload>();
            }
            preloaded.Add(preload);
        }
Пример #2
0
        private Preload(Preload preload, Substitutions substituter)
        {
            _base      = preload._base;
            views      = preload.views;
            auth       = preload.auth;
            signOwner  = preload.signOwner;
            signViewer = preload.signViewer;
            href       = _base.resolve(substituter.substituteUri(null, preload.href));
            Dictionary <String, String> attributes = new Dictionary <string, string>();

            foreach (var entry in preload.attributes)
            {
                attributes.Add(entry.Key, substituter.substituteString(null, entry.Value));
            }
            this.attributes = attributes;
        }
Пример #3
0
 private Preload(Preload preload, Substitutions substituter)
 {
     _base = preload._base;
     views = preload.views;
     auth = preload.auth;
     signOwner = preload.signOwner;
     signViewer = preload.signViewer;
     href = _base.resolve(substituter.substituteUri(null, preload.href));
     Dictionary<String, String> attributes = new Dictionary<string, string>();
     foreach (var entry in preload.attributes)
     {
         attributes.Add(entry.Key, substituter.substituteString(null, entry.Value));
     }
     this.attributes = attributes;
 }
Пример #4
0
 public void visit(XmlElement element)
 {
     Preload preload = new Preload(element, _base);
     if (preloaded == null)
     {
         preloaded = new List<Preload>();
     }
     preloaded.Add(preload);
 }
Пример #5
0
 public PreloadTask(GadgetContext context, Preload preload, String key) 
 {
     this.context = context;
     this.preload = preload;
     this.key = key;
 }