Пример #1
0
 /// <summary>
 /// Ctor.
 /// </summary>
 /// <param name="insertInto">the insert-into clause</param>
 /// <param name="selectClause">the select-clause</param>
 /// <param name="fromClause">the from-clause</param>
 /// <param name="whereClause">where-expression or null</param>
 public OnTriggerSplitStream(InsertIntoDesc insertInto, SelectClauseSpecRaw selectClause, OnTriggerSplitStreamFromClause fromClause, ExprNode whereClause)
 {
     InsertInto   = insertInto;
     SelectClause = selectClause;
     FromClause   = fromClause;
     WhereClause  = whereClause;
 }
Пример #2
0
 /// <summary>
 /// Ctor.
 /// </summary>
 /// <param name="splitterExpression">The splitter expression.</param>
 /// <param name="optionalResultEventType">Type of the optional result event.</param>
 /// <param name="optionalAsName">column name assigned, if any</param>
 /// <param name="optionalSelectClause">select clause, if any</param>
 /// <param name="optionalWhereClause">where clause, if any</param>
 public PropertyEvalAtom(ExprNode splitterExpression, String optionalResultEventType, String optionalAsName, SelectClauseSpecRaw optionalSelectClause, ExprNode optionalWhereClause)
 {
     SplitterExpression      = splitterExpression;
     OptionalResultEventType = optionalResultEventType;
     OptionalAsName          = optionalAsName;
     OptionalSelectClause    = optionalSelectClause;
     OptionalWhereClause     = optionalWhereClause;
 }
Пример #3
0
 /// <summary>Ctor. </summary>
 /// <param name="defaultStreamSelector">stream selection for the statement</param>
 public StatementSpecRaw(SelectClauseStreamSelectorEnum defaultStreamSelector)
 {
     OrderByList         = new List <OrderByItem>();
     StreamSpecs         = new List <StreamSpecRaw>();
     SelectClauseSpec    = new SelectClauseSpecRaw();
     OuterJoinDescList   = new List <OuterJoinDesc>();
     GroupByExpressions  = new List <GroupByClauseElement>();
     Annotations         = new List <AnnotationDesc>(1);
     SelectStreamDirEnum = defaultStreamSelector;
 }